aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 32 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 50df1af..0747857 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,10 +4,38 @@ AM_INIT_AUTOMAKE([-Wall -Werror, foreign])
AC_PROG_CC
-if [ ! -d "./linenoise/" ]
-then
- git clone --depth=1 'https://github.com/antirez/linenoise.git'
-fi
+AH_TEMPLATE([USE_READLINE], [do we use GNU Readline ?])
+AC_DEFUN([LINENOISE_URL], [https://github.com/antirez/linenoise.git])
+
+AC_CHECK_LIB([readline],
+ [readline],
+ [AC_DEFINE([USE_READLINE], [1])
+ use_readline=true
+ AC_ARG_WITH([readline],
+ AS_HELP_STRING([--without-readline],
+ [do not use GNU Readline, and use the Linenoise library
+ available at LINENOISE_URL]),
+ if test ! -d "./linenoise/"
+ then
+ git clone --depth=1 'LINENOISE_URL'
+ fi
+ AC_DEFINE([USE_READLINE], [0])
+ use_readline=false
+ )],
+ [AC_DEFINE([USE_READLINE], [0])
+ use_readline=true]
+)
+
+AM_CONDITIONAL([USE_READLINE_COND], [test x$use_readline = xtrue])
+
+AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],
+ [enable debugging, only useful for development])],
+ [debug=true],
+ [debug=false]
+)
+
+AM_CONDITIONAL([DEBUG_COND], [test x$debug = xtrue])
AC_CONFIG_FILES([
Makefile