aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-06-17 03:14:20 +0900
committerTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-06-17 03:14:20 +0900
commitcad449dff9c50bddcce41df04c5b3be771d28d04 (patch)
tree843a10df33202e06be4aca3ad381e4de18f20137 /configure.ac
parent2e5693e7cf1e3c408916a1af6d16dc6363b835fe (diff)
Improve build system
Add support for toggling debug on and off and for using GNU Readline or not.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 32 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 50df1af..0747857 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,10 +4,38 @@ AM_INIT_AUTOMAKE([-Wall -Werror, foreign])
AC_PROG_CC
-if [ ! -d "./linenoise/" ]
-then
- git clone --depth=1 'https://github.com/antirez/linenoise.git'
-fi
+AH_TEMPLATE([USE_READLINE], [do we use GNU Readline ?])
+AC_DEFUN([LINENOISE_URL], [https://github.com/antirez/linenoise.git])
+
+AC_CHECK_LIB([readline],
+ [readline],
+ [AC_DEFINE([USE_READLINE], [1])
+ use_readline=true
+ AC_ARG_WITH([readline],
+ AS_HELP_STRING([--without-readline],
+ [do not use GNU Readline, and use the Linenoise library
+ available at LINENOISE_URL]),
+ if test ! -d "./linenoise/"
+ then
+ git clone --depth=1 'LINENOISE_URL'
+ fi
+ AC_DEFINE([USE_READLINE], [0])
+ use_readline=false
+ )],
+ [AC_DEFINE([USE_READLINE], [0])
+ use_readline=true]
+)
+
+AM_CONDITIONAL([USE_READLINE_COND], [test x$use_readline = xtrue])
+
+AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],
+ [enable debugging, only useful for development])],
+ [debug=true],
+ [debug=false]
+)
+
+AM_CONDITIONAL([DEBUG_COND], [test x$debug = xtrue])
AC_CONFIG_FILES([
Makefile