aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 189162f..e3298be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,4 +7,13 @@ AC_CONFIG_FILES([
Makefile
src/Makefile
])
+AC_CHECK_PROG([DLPROG], [curl], [curl -LO], [false])
+if [ ! -d "./linenoise-master/" ]
+then
+ if [ ! -f "./master.zip" ]
+ then
+ $DLPROG 'https://github.com/antirez/linenoise/archive/refs/heads/master.zip'
+ fi
+ unzip 'master.zip'
+fi
AC_OUTPUT