aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-05-31 21:56:22 +0900
committerTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-05-31 21:56:22 +0900
commit1b50145b6f74f0d398bc01ae25d21fd18457a7c5 (patch)
tree111c1d1b5b3a1757ea49924c10fd6a1f4afd2842 /configure.ac
parente6aa60e042fce31347c297954b2b15c0875f3482 (diff)
Switch to linenoise instead of readline
The API is the exact same, and this implementation is much lighter and memory-leak-free.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 189162f..e3298be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,4 +7,13 @@ AC_CONFIG_FILES([
Makefile
src/Makefile
])
+AC_CHECK_PROG([DLPROG], [curl], [curl -LO], [false])
+if [ ! -d "./linenoise-master/" ]
+then
+ if [ ! -f "./master.zip" ]
+ then
+ $DLPROG 'https://github.com/antirez/linenoise/archive/refs/heads/master.zip'
+ fi
+ unzip 'master.zip'
+fi
AC_OUTPUT