aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-05-31 23:20:08 +0900
committerTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-05-31 23:20:08 +0900
commit8a19837e71773af2405b6c4c64eeef0fbc9e3b22 (patch)
tree4cec71aaf1b63935f556f5d57f6478cffdf24cef /configure.ac
parent1b50145b6f74f0d398bc01ae25d21fd18457a7c5 (diff)
Fix the build system
Simply use git to retrieve linenoise sources instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index e3298be..3eaec37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,13 +7,10 @@ AC_CONFIG_FILES([
Makefile
src/Makefile
])
-AC_CHECK_PROG([DLPROG], [curl], [curl -LO], [false])
-if [ ! -d "./linenoise-master/" ]
+
+if [ ! -d "./linenoise/" ]
then
- if [ ! -f "./master.zip" ]
- then
- $DLPROG 'https://github.com/antirez/linenoise/archive/refs/heads/master.zip'
- fi
- unzip 'master.zip'
+ git clone --depth=1 'https://github.com/antirez/linenoise.git'
fi
+
AC_OUTPUT