aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-06-30 17:00:48 +0900
committerTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-06-30 17:00:48 +0900
commitc48f0176412f2c15fbb3cbc6052550959f581da9 (patch)
tree8d637080281f0b50f3a303e5a62ccb44e2201b21 /src/Makefile.am
parent46e6de294243e8dc593551bfe8c0e7090d03a159 (diff)
Add support for release compilation modeHEADmaster
Displays are not shared libraries, but object files that are part of the final executable.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d8f6457..3c4c982 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,7 +28,9 @@ linenoise_lib.c:
endif # USE_READLINE_COND
else # DEBUG_COND
-AM_CFLAGS += -DNDEBUG -Wno-unused-variable
+AM_CFLAGS += -DNDEBUG
+calculer_SOURCES += calc_data.c input.c cli.c tui.c ray.c
+AM_LDFLAGS += -lncurses
if USE_READLINE_COND
AM_LDFLAGS += -lreadline