aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-06-28 16:35:27 +0900
committerTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-06-28 16:36:35 +0900
commitc21b78b105be95bc48d31d9b55e3877c34a666b2 (patch)
treeeadce2696ad980e5d77ad119a5b922a67252f26f /src/Makefile.am
parentea9f134df9b83a7c4aa74737055a8a131c65e25d (diff)
Integrate the new text interface
A couple pieces of code have been made independant from the GUI implementation: calc_data and input.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ba7136b..d8f6457 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,7 +6,7 @@ calculer_SOURCES = calculer.c disp.c
if DEBUG_COND
noinst_LTLIBRARIES = ray.la
-ray_la_SOURCES = ray.c
+ray_la_SOURCES = ray.c calc_data.c input.c
ray_la_LDFLAGS = -module -rpath @abs_srcdir@ -lraylib
noinst_LTLIBRARIES += cli.la
@@ -14,7 +14,7 @@ cli_la_SOURCES = cli.c
cli_la_LDFLAGS = -module -rpath @abs_srcdir@
noinst_LTLIBRARIES += tui.la
-tui_la_SOURCES = tui.c
+tui_la_SOURCES = tui.c calc_data.c input.c
tui_la_LDFLAGS = -module -rpath @abs_srcdir@ -lncurses
if USE_READLINE_COND