aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-05-31 21:56:22 +0900
committerTristan Riehs <tristan.riehs@bordeaux-inp.fr>2024-05-31 21:56:22 +0900
commit1b50145b6f74f0d398bc01ae25d21fd18457a7c5 (patch)
tree111c1d1b5b3a1757ea49924c10fd6a1f4afd2842 /src/Makefile.am
parente6aa60e042fce31347c297954b2b15c0875f3482 (diff)
Switch to linenoise instead of readline
The API is the exact same, and this implementation is much lighter and memory-leak-free.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ddf7c6b..728ef88 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,7 @@
bin_PROGRAMS = calculer
-AM_CFLAGS = -std=c99 -Wall -Wextra
-AM_LDFLAGS = -lreadline
-calculer_SOURCES = calculer.c
+AM_CFLAGS = -Wall -Wextra -I../linenoise-master/
+calculer_SOURCES = calculer.c linenoise.c
+BUILT_SOURCES: linenoise.c
+
+linenoise.c:
+ cp ../linenoise-master/linenoise.c .